Repository Forums Support WooCommerce Extended Coupon Features PRO Possible bug – Coupons are automatically readded with debugging turned off

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #19737
    Iris ter Haar

    – WooCommerce with WooCommerce Blocks plugin, custom theme, WooCommerce extended coupon plugin

    Tested and bug confirmed with following active:
    – Storefront theme, twenty twenty two theme, WooCommerce plugin, WooCommerce Extended coupon plugin. All other plugins deactivated.

    We use a coupon code for customers if they forget to order something with their current order. This reduces the shipping costs to 0 as we can add it to another order. After the order is placed, the coupon is readded to the shopping cart immediately after reloading the website.

    We would like to make sure coupons are not readded to the shopping cart after the order is completed.

    The coupons are not autocoupons.

    When we turn debugging on and turn off autocoupon in the debugging settings, the plugin performs as we want it to. However, we now receive notices that we should turn off debugging.

    Can you please advise?

    To reproduce:

    – Install any theme with WooCommerce
    – Install WooCommerce Extended Coupon Features Pro
    – Create coupon code with no usage limit, no expiration date, no autocoupon

    Add to cart. Order. Go to home page after order. See that notice displays that coupon is added to the cart again.

    Turn on debugging and make sure ‘autocoupon’ is turned off. Test again. See it now works as we expect.

    If needed, we can create a staging environment with credentials.


    Could you try turning off ‘Allow applying when invalid’ on the Miscellaneous tab of the coupon? Does that fix the issue?

    Iris ter Haar

    The issue is now fixed, thanks! However, we keep getting a notice in the admin that reads:

    “WooCommerce Extended Coupon Features – Laden van plugin pro-coupon-queueing: Missing dependency autocoupon is mislukt.”

    We cannot dismiss this notice


    Oh, I think you can just enable autocoupon again. Turning off ‘Allow applying when invalid’ on the Miscellaneous tab of the coupon should be enough.

    I will try to reproduce this issue locally and see if a fix is required, but it will take a while.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.